Responsive Ads Here

Monday, November 24, 2014

11677- Alarm Clock

11677- Alarm Clock

Alarm Clock

Daniela is a nurse in a large hospital, which causes her working shifts to constantly change. To make it worse, she has deep sleep, and a difficult time to wake up using alarm clocks.

Recently she got a digital clock as a gift, with several different options of alarm sounds, and she has hope that it might help solve her problem. But, lately, she's been very tired and want to enjoy every single moment of rest. So she carries her new clock to every place she goes, and whenever she has some spare time, she tries to sleep, setting her alarm clock to the time when she needs to wake up. But, with so much anxiety to sleep, she ends up with some difficulty to fall asleep and enjoy some rest.

A problem that has been tormenting her is to know how many minutes of sleep she would have if she felt asleep immediately and woken up when the alarm clock ringed. But she is not very good with numbers, and asked you for help to write a program that, given the current time and the alarm time, find out the number of minutes she could sleep.

Input

The input contains several test cases. Each test case is described in one line, containing four integers H1, M1, H2 and M2, with H1 : M1 representing the current hour and minute, and H2 : M2 representing the time (hour and minute) when the alarm clock is set to ring ( 0$ \le$H1$ \le$23, 0$ \le$M1$ \le$59, 0$ \le$H2$ \le$23, 0$ \le$M2$ \le$59).

The end of the input is indicated by a line containing only four zeros, separated by blank spaces.

Output

For each test case, your program must print one line, containing a single integer, indicating the number of minutes Daniela has to sleep.

Sample Input

1 5 3 5
23 59 0 34
21 33 21 10
0 0 0 0

Sample Output

120
35
1417


#include<stdio.h>
int main()
{int a,b,c,d;
    while(scanf("%d%d%d%d",&a,&b,&c,&d)!=EOF)
    {   int H,h,m,M,sum;
        if((a==0)&&(b==0)&&(c==0)&&(d==0))
        {
            break;
        }
    if(c==0)
    {
        c=24;
    }
    if(a==0)
    {
        a=24;
    }
 
    if(c>a)
    {
        H=((c*60)+d)-((a*60)+b);
 
    }
    else if((a==c)&&(b<d))
    {
        H=((c*60)+d)-((a*60)+b);
    }
else if(a>c)
    {
        H=(((c+24)*60)+d)-((a*60)+b);
    }
else if((a==c)&&(b>d))
    {
        H=(((c+24)*60)+d)-((a*60)+b);
    }
    printf("%d\n",H);
}
return 0;
}

 


 


11677- Alarm Clock uva link

No comments:

Post a Comment

php4

<?php    // Start the session  session_start();  ?>  <!DOCTYPE html>  <html>  <head>       <link rel=&q...