Responsive Ads Here

Thursday, September 17, 2015

UVA-382–Perfection- Using java And C

UVA-382–Perfection- Using java

382 - Perfection
Time limit: 3.000 seconds

Perfection

From the article Number Theory in the 1994 Microsoft Encarta: ``If a, b, c are integers such that a = bc, a is called a multiple of b or ofc, and b or c is called a divisor or factor of a. If c is not tex2html_wrap_inline41 , b is called a proper divisor of a. Even integers, which include 0, are multiples of 2, for example, -4, 0, 2, 10; an odd integer is an integer that is not even, for example, -5, 1, 3, 9. A perfect number is a positive integer that is equal to the sum of all its positive, proper divisors; for example, 6, which equals 1 + 2 + 3, and 28, which equals 1 + 2 + 4 + 7 + 14, are perfect numbers. A positive number that is not perfect is imperfect and is deficient or abundant according to whether the sum of its positive, proper divisors is smaller or larger than the number itself. Thus, 9, with proper divisors 1, 3, is deficient; 12, with proper divisors 1, 2, 3, 4, 6, is abundant."

Problem Statement

Given a number, determine if it is perfect, abundant, or deficient.

Input

A list of N positive integers (none greater than 60,000), with 1 < N < 100. A 0 will mark the end of the list.

Output

The first line of output should read PERFECTION OUTPUT. The next N lines of output should list for each input integer whether it is perfect, deficient, or abundant, as shown in the example below. Format counts: the echoed integers should be right justified within the first 5 spaces of the output line, followed by two blank spaces, followed by the description of the integer. The final line of output should read END OF OUTPUT.

Sample Input

15 28 6 56 60000 22 496 0

Sample Output

PERFECTION OUTPUT
15 DEFICIENT
28 PERFECT
6 PERFECT
56 ABUNDANT
60000 ABUNDANT
22 DEFICIENT
496 PERFECT
END OF OUTPUT

 

Using Java



import java.util.Scanner;
public class Main {
 
    public static void main(String[] args) {
        int a;
        System.out.println("PERFECTION OUTPUT");
        Scanner s=new Scanner(System.in);
         while(s.hasNext())
         {
             a=s.nextInt();
             if(a==0)
                {
                 System.out.println("END OF OUTPUT");
                    break;
                }
             int n=a,i,sum=0;
             for(i=1;i<a;i++)
             {
                 if(n%i==0)
                 sum=sum+i;
             }
             if(sum==a)
             {    
                 
                 System.out.format("%5d  PERFECT\n", a);
             }
             else if(sum>a)
             {    
                 
                 System.out.format("%5d  ABUNDANT\n", a);
             }
             else if(sum<a)
             {    
                 
                 System.out.format("%5d  DEFICIENT\n", a);
             }
 
         }
         }
        
        
    }
 


Using C



#include<stdio.h>
int main()
{
     int a;
     printf("PERFECTION OUTPUT\n");
     while(scanf("%d",&a)!=EOF)
     {
            if(a==0)
            {
                printf("END OF OUTPUT\n");
                break;
            }
            int n=a,i,sum=0;
         for(i=1;i<a;i++)
         {
             if(n%i==0)
             sum=sum+i;
         }
         if(sum==a)
         {
             printf("%5d PERFECT\n",a);
         }
         else if(sum>a)
         {
             printf("%5d ABUNDANT\n",a);
         }
         else if(sum<a)
         {
             printf("%5d DEFICIENT\n",a);
         }
 
     }
    return 0;
 
}

No comments:

Post a Comment

php4

<?php    // Start the session  session_start();  ?>  <!DOCTYPE html>  <html>  <head>       <link rel=&q...